1

Topic: Slideshow appearance, hiding player, play on click + player size

Apologies if this has been covered before, I am new to the forum. I want to add two features to slideshows I'm outputting.

I would like to be able to have the slideshow play on clicking the screen image (I tried just turning off player in the slideshow setup, no luck)

It would look much neater if the control bar/player at the bottom of the screen was the same width as my images, is there an easy way to do this.

Last question I tired the Ipad autodetect shell but my show doesnt appear when I use my ipad to check my blog.

Thanks in advance, Damian. If these topics have been covered would be grateful if someone could post the links for the particular posts.

2

Re: Slideshow appearance, hiding player, play on click + player size

Hi Damian.

damiandrohan wrote:

I would like to be able to have the slideshow play on clicking the screen image (I tried just turning off player in the slideshow setup, no luck)

That's possible via the "Advanced parameters" (Modify > Advanced parameters).  From there you should see a parameter named "click_to_play".  Change that parameter's value to "true".

Here's an example with "click to play" set to "true".
http://media.soundslides.com/examples/fullscreen/

damiandrohan wrote:

It would look much neater if the control bar/player at the bottom of the screen was the same width as my images, is there an easy way to do this.

The control bar is the width of the player, so you'll probably have to change the size of the output to match the aspect ratio of your images.  See the above example (which uses an output size that matches the images).

damiandrohan wrote:

Last question I tired the Ipad autodetect shell but my show doesnt appear when I use my ipad to check my blog.

The iPad shell that's included with the beta isn't embeddable (since the iPad needs an entirely new embed method in addition to the new player).  We just added a new shell that can be embedded for iPad. 

You can download the shell from here and install it in your application's shells folder.  Note that the new embed method does not use our standard embed tool.


Let me know if you have anymore questions or if I missed the point on any of your questions.

joe

3

Re: Slideshow appearance, hiding player, play on click + player size

Folowing from previous questions, I downloaded the ipad embeddable shell and have exported files and uploaded to the server, when I enter the url in my web browser it opens fine, when I enter the url and ?embed in a wordpress post and examine the post all I get is the url, no slideshow,

here's the url: http://www.ww2vetsproject.com/?p=4

I would appreciate help as I am rushing to get my MA Photojournalism project completed and online asap. I tried the url and ?embed in html and text editing mode and tried surrounding with [] brackets, is there something I am missing?

Here is exactly what I type into the wordpress post:

http://www.ww2vetsproject.com/wp-conten … ?embedcode

One of the themes I am trying to use has an embed url box, when I type the above in that box I get a link appearing  on the post which brings me  to a screen which generates a code for an iframe which will display the slideshow using the following embed code:

<iframe src="http://www.ww2vetsproject.com/wp-content/ww2vetsuploads/frankh/publish_to_web/_files/iframe.html" width="480" height="320" scrolling="no" frameborder="0"></iframe>

except with this code no matter what values I enter the player is always smaller than the picture which is very annoying as the original show is set so that the player and image are the same size.

Help please, I am under severe pressure to get this stuff finished on time

4

Re: Slideshow appearance, hiding player, play on click + player size

Hi Damian.

I'm sorry, I'm a bit confused as to what's going on.

The first link to your blog, it appears that you've just linked to the embed generator.  You'll need to instead post the actual "iframe" code into the blog post instead.

The "iframe" code is a replacement for the standard "embed" code that is used for Flash.  You can only use the iframe method if your blog system supports using iframe tags.

As for maintaining the aspect ratio, try 500x533, as that's what you've used in the original slide show.

Here's what I'd like you to try posting into your blog:

<iframe src="http://www.ww2vetsproject.com/wp-content/ww2vetsuploads/frankh/publish_to_web/_files/iframe.html" width="500" height="533" scrolling="no" frameborder="0"></iframe>

Let me know if that works.

joe

5

Re: Slideshow appearance, hiding player, play on click + player size

HI Joe, I will try that, I'm also a little confused as the actual slideshow output is set to 500x500 in the soundslides project, I just double checked to make sure, when I test the slideshow prior to uploading it looks fine, the player matches the output at 500x500, does it have anything to do with whether controls/footer are turned on or off when you are setting up your project,

thanks

Damian

6

Re: Slideshow appearance, hiding player, play on click + player size

Ok that seems to work, I'm a little confused as to where the 500x533 comes from as the slideshow is definitely set to 500x500, does it add 33px extra for the player?

I'll try it with the other work, hopefully that will sort things out, for the moment then everything seems to be okay, if you could shed some light on the 533 that would be great

Thanks for your help

Damian

7

Re: Slideshow appearance, hiding player, play on click + player size

Hi Damian,

I'm glad that worked.

500x500 is the image output size in your slide show.  The controls add 33 pixels to the total height of the player.

To find your player's dimension, just look at the source code from your slide show.

If you look at your source code on this page:
http://www.ww2vetsproject.com/wp-conten … index.html

You'll see the player dimensions listed ...

    embed_width: 500,
    embed_height: 533,

Hope that helps.

joe

8 (edited by damiandrohan 2010-11-13 05:05:11)

Re: Slideshow appearance, hiding player, play on click + player size

another weird one for you, outputting shows and when I select default and have a 500x500 output the player matches the width of the show exactly, when I select ipad embeddable with exactly the same settings and test in the browser (prior to upload) the layer appears to be a few pixels longer than the width of the image. Weird and very annoying when you're trying to get everything to match up.


Not only that but a comparison between the default and the ipad embeddable version side by side testing in the browser prior to upload reveals that the ipad embeddable definitely softens the image compared to the default. Help!!!!!
any suggestions?

I tried Ipad autodetect and I don't get the loss of sharpness or the difference in the player size, is there any way to embed ipad autodetect (as opposed to embeddable- and have it show up on ipads)

thanks

damian

9

Re: Slideshow appearance, hiding player, play on click + player size

I'm assuming you're talking about this page:
http://www.ww2vetsproject.com/?p=4

I've emailed you a new "iframe.html" page for you to put in your "_files" folder on your web server.  Let me know if that makes a difference.

It appears that there are some inconsistencies between browsers that is causing you an issue.  I'm trying to workaround them.

joe

10

Re: Slideshow appearance, hiding player, play on click + player size

Thanks Joe, you've gone above and beyond on this, I will have twenty or so of these guys to embed, forgive my ignorance, I'm not a programmer, just a photographer struggling to get his head around enough of this stuff to make my stuff look good.

I have to ask a silly question, what do I do with the new iframe, in other words how do I incorporate it? is it a case of putting it in the publish_to_web folder on the server for each show that I upload? and then changing the specifics on embed?

many thanks

Damian

11

Re: Slideshow appearance, hiding player, play on click + player size

You shouldn't have to change any specifics on embed. 

You just need to put that file in the "_files" folder (which is in your "publish_to_web" folders).

Just do one and make sure that it works before doing that to all 20.

I'll be offline most of today, but I'll try to check in around 1700 GMT.

All this iPad stuff really is *beta*, so I appreciate that everyone on the forum has been so cool about posting the issues they are finding.  We're concentrating on this thing, and we hope to have it nailed solid by next week.  So far, this embed issue is the main thing we're focusing on.

-joe

12

Re: Slideshow appearance, hiding player, play on click + player size

much appreciated joe, will try one or two and let you know if there are issues.

13

Re: Slideshow appearance, hiding player, play on click + player size

HI Joe, I just want to clarify one thing.

Firstly thanks you for going to so much trouble to sort this out for me. I really appreciated it.

As I mentioned the ipad embeddable shell softens the image compared to the autodetect or default. Is the autodetect version embeddable?

I just want to know for sure before I go making twenty of them. I can't use the ipad embeddable at present because it 100% definitely softens the pics, I've looked at both, side by side,

many thanks

Damian

14

Re: Slideshow appearance, hiding player, play on click + player size

Hi Damian.

The autodetect version is not embeddable for iPad.

However, I know what causes the softness issue that you were seeing.  There is some scaling that is applied to the embed version to make it fit inside the iframe. 

I didn't see it before, but I see it now that you've uploaded that test file I sent.

If I add an option to disable scaling, you should be able to embed it without applying any scaling.  Let me work on this for an hour or so and get you a new shell to test.

joe

15

Re: Slideshow appearance, hiding player, play on click + player size

Hi Damian,

Also, it would help me tremendously if you could post the URL of your side by side tests.  I'm testing here with images, but it would help to see what you're judging off of.

thanks
joe

16

Re: Slideshow appearance, hiding player, play on click + player size

Here's the new shell:
http://media.soundslides.com/release/sh … ddable.zip

I named it "autodetect_embeddable" to differentiate it from the others.

When you get the embed code, you'll see that there's a new 'non-scaling' embed code option.  That's the one you should use.

If possible, please post examples of this shell and the default shell if you're seeing a noticeable difference.

Thanks.
joe

17

Re: Slideshow appearance, hiding player, play on click + player size

Thanks so much Joe, you've gone above and beyond on this. I will test it out and see what happens, thanks Damian

18

Re: Slideshow appearance, hiding player, play on click + player size

HI Joe, have been testing the auto_detect embeddable, on my computer everything looks fine, I copied the new iframe.html into the files folder of the publish_to_web and uploaded it

on the post i typed the following embed code:
<iframe src="http://www.ww2vetsproject.com/wp-content/ww2vetsuploads/billyod/publish_to_web/_files/iframe.html" width="500" height="533" scrolling="no" frameborder="0"></iframe>

which matches the location of the new uploaded folder, and I get a blank screen

the url is here: http://www.ww2vetsproject.com/?p=4

any help would be appreciated, I have everything ready to go but I have to get the basics right first, then customize the blog,

thanks

Damian

19

Re: Slideshow appearance, hiding player, play on click + player size

I'm investigating it now.  I get the same blank screen here as well.

20

Re: Slideshow appearance, hiding player, play on click + player size

Actually, the shell looks correct. 

Are you sure you copied over the "_files" folder to your server after you re-exported with the new shell?

-joe

21

Re: Slideshow appearance, hiding player, play on click + player size

damiandrohan wrote:

I copied the new iframe.html into the files folder of the publish_to_web and uploaded it

Ah, I think there's some confusion.  That's my fault.

This new shell incorporates all the previous changes into it.  So you don't have to use that custom "iframe.html" file that I sent this past week.  Just use the "publish_to_web" folder as is ... it should work without adding anything to it.

Just export as usual, and upload.

As for the embed code, if you go to this page:
http://www.ww2vetsproject.com/wp-conten … ?embedcode

... you'll see two versions of the embed code.  Make sure to use the second one.  That's the one that uses the "noscale" option.

-joe

22

Re: Slideshow appearance, hiding player, play on click + player size

Thanks Joe, that's working great now. Really appreciate the time and effort you out into getting this sorted for me,

best

Damian

23

Re: Slideshow appearance, hiding player, play on click + player size

HI Joe, the shows are displaying and playing fine on PC. On the ipad there is a medium thickness black line at the top and bottom of the the image and when you click play the button reverts to a pause button and nothing happens, the show doesnt play and the time doesnt count down. Sorry to be the bearer of more hassle

regards

Damian

24

Re: Slideshow appearance, hiding player, play on click + player size

I'll check it out, but I need a link.

I'm not seeing any slide show at the previous link.

25

Re: Slideshow appearance, hiding player, play on click + player size

Found it ... I'm guessing you're working on this as I was looking at it. I'm working on it now.