26

Re: ipad [yes, bloody ipad]

joeweiss wrote:

Sorry for the confusion. 

The entire "iDetect_embeddable" folder should be moved into "shells".  All the enclosed files should remain inside of that folder. It should appear just like the other folders.


Thanks, I understand that, but in the archive there are many files outside of the iDetect_embeddable folder. Where do those go?

I have a screen capture to help me explain.

http://joemezz.com/help.jpg

thanks,
Joe

27

Re: ipad [yes, bloody ipad]

Hi Joe.

That's very weird. I don't know why those "invisible" files are showing up when unzipped. 

The contents of "iDetect_embeddable" should just be 1 folder and 3 files.

_files
README.txt
decom.html
index.html

I'll re-output the zip Monday morning and post the link as soon as I get into the office.

-joe

28

Re: ipad [yes, bloody ipad]

OK, I cleaned up the zip.

http://media.soundslides.com/release/sh … _shell.zip

The entire "iDetect_embeddable" folder should be moved into "shells".

Let me know if that's better.

joe

29

Re: ipad [yes, bloody ipad]

joeweiss wrote:

OK, I cleaned up the zip.

http://media.soundslides.com/release/sh … _shell.zip

The entire "iDetect_embeddable" folder should be moved into "shells".

Let me know if that's better.

joe

really appreciate your time, but still do not know what to do what the files not in the iDetect_embeddable folder.

Your instructions say "Just unzip it an copy the "iDetect_embeddable" folder into your Soundslides or Soundslides Plus "shells" folder" ...

Sorry to be a  pain!   :-)



11/15/2010  11:04 PM    <DIR>          .
11/15/2010  11:04 PM    <DIR>          ..
11/15/2010  11:09 AM    <DIR>          _files
11/15/2010  11:09 AM    <DIR>          iDetect_embeddable
11/15/2010  11:10 AM    <DIR>          iPad_shell
05/13/2010  11:36 AM             6,328 buttons.png
07/01/2010  04:11 PM             2,123 decom.html
11/15/2010  11:04 PM                 0 files.txt
10/29/2010  02:10 PM             1,999 iframe.html
10/29/2010  03:51 PM             2,990 index.html
05/04/2010  04:02 PM            23,413 jquery.jplayer.js
04/30/2010  12:59 PM            72,174 jquery1.4.2.min.js
10/29/2010  03:51 PM               238 README.txt
06/04/2010  11:27 AM             3,261 soundslides.css
10/29/2010  02:51 PM            24,453 soundslides.js
07/06/2008  04:25 PM             9,759 swfobject.js

30

Re: ipad [yes, bloody ipad]

I'm not sure how that's happening, but it appears that whatever you're using to unzip is putting all the files in one directory.  What are you using?  I just unzipped it on XP, Vista and Win7 without issue.

It looks like you've got all the files though, so perhaps it would be easy just to move the files into the right structure.

Here's the structure described as text.  Both "iDetect_embeddable" and "_files" are folders.

iDetect_embeddable
    index.html
    README.txt
    decom.html
    _files
        buttons.png
        iframe.html
        jquery.jplayer.js
        jquery1.4.2.min.js
        soundslides.css
        soundslides.js
        swfobject.js


And here's a screenshot from a Mac, though this should at least show how to arrange them:

http://media.soundslides.com/files/embed_shell.jpg

31

Re: ipad [yes, bloody ipad]

I just erased my downloads directory - re-downloaded it - and .. yes - you are correct. It's fine (Using Win7 and 7ZIP) - - I don't know why it was weird.

But all set now.. *thank you*

32 (edited by theMezz 2010-11-15 22:55:45)

Re: ipad [yes, bloody ipad]

I ran it and it works - but the mp4 lacks the Ken Burns effects that was in the slideshow

thanks,
Joe

33

Re: ipad [yes, bloody ipad]

I've fixed two problems with the iDetect shell.

1) There was an issue with some versions of IE and Firefox
2) The non-Flash version displayed the caption and credits button even if those features were disabled.

The new shell can be downloaded from here:
http://media.soundslides.com/release/shells/idetect.zip

Thanks for all the comments.

joe

34

Re: ipad [yes, bloody ipad]

GREAT - -  *thank you*

35

Re: ipad [yes, bloody ipad]

Hm, I can't figure out what I'm doing wrong here. Is it that four-second rule? No tests or anything will get it to run on the iPhone or iPad:

http://www.ryanbrenizer.com/blog/slides … a-and-sam/

36

Re: ipad [yes, bloody ipad]

There is no four second rule. That was a bug that was fixed (as far as I know).

This one looks different.  It looks like the slide show is throwing an error because of something in the xml.  I'll investigate now.

Thanks for posting the example link.

joe

37

Re: ipad [yes, bloody ipad]

There was an invalid invisible character in the headline of your slide show file.  It looks like the iPad is much more strict than Flash at parsing those characters.

As a quick fix, I manually removed the invisible character from your soundslide.xml file.  You can download it here:

http://media.soundslides.com/files/f_ry … dslide.xml

Can you download that file and copy it into your "leila_sam" folder on your site?

Let me know how it goes.

joe

38

Re: ipad [yes, bloody ipad]

Hi Joe,
thanks for all your efforts. I've just downloaded the new shell. Do we still use index.html?embedcode ?
I'll roll it out and test later today.
Thanks again.

JOHN DONEGAN

39

Re: ipad [yes, bloody ipad]

Yes, the embed code generator works in the same manner as before.  Let me know how it goes.

joe

40

Re: ipad [yes, bloody ipad]

hi joe.
i've got the same problem as before.
www.1826media.com.au/test001/index.html works beautifully on the ipad.
when i embed the code into another page - www.1826media.com.au/test001.html - the ss doesn't play. the pictures are there and i can scroll through them, but the play button is impotent.
I'm guessing it is a problem at my end, and I'll keep exploring my html, but any help would be greatly appreciated.

cheers.
John D

41

Re: ipad [yes, bloody ipad]

Ah, I think that's fixed.  The problem was that the audio wasn't always playing when embedded in an iframe.

OK, I've got yet another shell ready.  Here's the new shell:
http://media.soundslides.com/release/sh … ed.0.2.zip

And here's a test that displays a slide show within an iframe:
http://media.soundslides.com/files/2010 … dtest.html

The audio plays on the iPads here.

Let me know how that goes.

joe

42

Re: ipad [yes, bloody ipad]

Brilliant. Thanks for all your efforts Joe. If you're ever down-under I'll buy you a beer (or ten).
Cheers,
John Donegan.

43

Re: ipad [yes, bloody ipad]

Hey Joe, i saw this topic and tested the html5 shell to see if firefox displayed the colors correct (witch firefox doesn't do with flash). I don't know much about coding but I just changed the flash version in the index.html from 9 to 11 so that firefox played the JS slideshow instead of the flash slideshow. smile

The colors were correct, not over saturated like they are with flash on wide gammut displays!

So my question: is it possible to make a shell that is html5 in default and still acts like the flash slideshows? (so with sound, and movement...)

I know there are propabely alternatives for making html5 slideshows, but I really like to use the soundslides program. It's fast and simple.

44

Re: ipad [yes, bloody ipad]

Hi DriesRenglé;

I posted an answer in the other thread since they're related:
http://forums.soundslides.com/viewtopic … 350#p10350

-joe

45

Re: ipad [yes, bloody ipad]

i installed the newest version of the shell in order to have my slideshow be viewable on iphones/ipads. 

i haven't been able to try it out on an ipad yet, but when i view the slideshow on my iphone, the pictures stop loading about 2/3 of the way in.  the music will continue to play, and the timer will continue to count down, but the pictures just go black and stay that way for the duration.

any ideas?

46

Re: ipad [yes, bloody ipad]

Hi Matt.

Can you post the URL and I'll check it out on our iPhones and iPads?

One of the items that I'm finding inconsistent about the iPhone versus iPad browser is how the image loading is reported to the HTML5 code; so your link would help me a lot especially if it consistently behaves in the same manner.

It seems that when the connection slows, then the browser gives "priority" to the audio, rather than reporting that the images are yet to be loaded.

thanks
joe

47

Re: ipad [yes, bloody ipad]

Thanks for the link Matt.

I'm pretty sure I see the problem, and I've got a new shell for you to try.

http://media.soundslides.com/release/sh … ed.0.3.zip

This is the "autodetect_embed.0.3" shell.

Install the shell, then change the shell setting (Template tab > Shell tab), then re-export and upload to your web server.

Clearing the cache on an iPhone is a pain, so you might just want to put it in a new folder on your server when you're uploading.

Let me know how it goes.

-joe

48

Re: ipad [yes, bloody ipad]

thanks for the quick response joe, it played all he way through with the new shell.

49

Re: ipad [yes, bloody ipad]

That worked for that page, thank you! Is there anything I should do differently so I don't have to manually check XML files in the future?

50

Re: ipad [yes, bloody ipad]

Hi again! I was just wondering if there's a way to call a function when the slideshow ends using the HTML5 code. I checked the jPlayer options and there's a way using onSoundComplete (if I remember well) but I've tried and I can't make it work.

Also, I tried using the javascript path option and it doesn't seem to be working either. That's not a biggie though.

Any help will be great. Thanks so much!